Search found 196 matches

by j12t
Sun Aug 22, 2021 8:04 pm
Forum: Virtualization and Cloud
Topic: Shepherd user on a virtual server
Replies: 2
Views: 144

Re: Shepherd user on a virtual server

What issues are you running into when attempting to attach a UBOS Staff device to your virtual machine? Which platform are you on.

Secondly, you are looking for:

Code: Select all

% sudo ubos-admin setup-shepherd
Also see

Code: Select all

% ubos-admin --help
by j12t
Sat Aug 14, 2021 3:27 am
Forum: UBOSbox
Topic: Mastodon not working
Replies: 1
Views: 106

Re: Mastodon not working

Probably needs a rebuild. In the next apps update. https://github.com/uboslinux/ubos-app-mastodon/issues/31 If you want to work on it: determine whether Mastodon works with Ruby 3, if so, upgrade the PKGBUILD. If not, we have ruby2.7 package in the repo which we created for Decko, e.g. see commit lo...
by j12t
Mon Aug 09, 2021 6:35 pm
Forum: UBOSbox
Topic: Refuse to restore ubos-backup
Replies: 4
Views: 211

Re: Refuse to restore ubos-backup

Hmm, my best guess is that there is some corruption in the zip file, and when we are trying to unpack it, that fails. So the restore command says essentially "I failed to unpack this, so it must be a format I don't recognize". The next thing to try would be to see whether other tools also ...
by j12t
Sun Aug 08, 2021 9:57 pm
Forum: UBOSbox
Topic: Refuse to restore ubos-backup
Replies: 4
Views: 211

Re: Refuse to restore ubos-backup

Can you run it with two "-v" flags for lots of debug output? (Never seen this one before)
by j12t
Fri May 28, 2021 9:25 pm
Forum: UBOSbox
Topic: LetsEncrypt Certificate Did Not Auto-Renew
Replies: 8
Views: 1154

Re: LetsEncrypt Certificate Did Not Auto-Renew

I would compare DNS settings for the domains.

For restarting certbot, see above.
by j12t
Fri May 21, 2021 11:03 pm
Forum: UBOSbox
Topic: LetsEncrypt Certificate Did Not Auto-Renew
Replies: 8
Views: 1154

Re: LetsEncrypt Certificate Did Not Auto-Renew

This means Letsencrypt could not verify that you actually own the site. And as I said earlier, that usually happens when the networking setup does not permit Letsencrypt access your site from the public internet. So make sure that works: DNS, Pagekite, port forwarding or whatever you do there. sudo ...
by j12t
Fri May 21, 2021 12:16 am
Forum: UBOSbox
Topic: LetsEncrypt Certificate Did Not Auto-Renew
Replies: 8
Views: 1154

Re: LetsEncrypt Certificate Did Not Auto-Renew

The log probably has some info about that. Also, when you restart the service, does it fail again?
by j12t
Wed May 19, 2021 3:19 am
Forum: UBOSbox
Topic: LetsEncrypt Certificate Did Not Auto-Renew
Replies: 8
Views: 1154

Re: LetsEncrypt Certificate Did Not Auto-Renew

UBOS is attempting to renew the certificate once a day until it is successful. For that to work, your UBOSbox needs to be on at that time, and reachable from the public internet. To see what happened: sudo systemctl status certbot.service and sudo journalctl -u certbot.service As root, you can also ...
by j12t
Tue Mar 02, 2021 7:34 pm
Forum: Other
Topic: Install UBOS on Odroid HC-2 failed
Replies: 5
Views: 1374

Re: Install UBOS on Odroid HC-2 failed

Updated the armv7h images. Should work better now. Please report if they don't :-)
by j12t
Mon Mar 01, 2021 5:38 pm
Forum: Other
Topic: Install UBOS on Odroid HC-2 failed
Replies: 5
Views: 1374

Re: Install UBOS on Odroid HC-2 failed

Could you try with the image from the yellow release channel here? http://depot.ubos.net/yellow/armv7h/images/