nextcloud + mac os x Contacts app

You are using UBOS on a Rasberry Pi. Please state which model you are using, e.g. Zero, Zero W, model 3 or such.
Post Reply
Posts: 3
Joined: Fri Jan 05, 2018 7:54 am

nextcloud + mac os x Contacts app

Post by mike865 »

I got nextcloud working with my iphone (joy!), but I noticed only the calendar worked with mac os x (10.11)

I could add the account to the mac contacts app, but it would soon fail on the first operation,
showin this error message:

The operation couldn’t be completed.
(CoreDAVHTTPStatusErrorDomain error 405.)

tracking it down in the logs, I found these messages:

xxx ubos-device - [xxx] "PROPFIND /.well-known/carddav HTTP/1.1" 405 778
xxx ubos-device - [xxx] "PROPFIND / HTTP/1.1" 200 883
xxx ubos-device - [xxx] "PROPFIND /principals/ HTTP/1.1" 405 778

I had installed nextcloud on /nextcloud, and tried reinstalling it without a prefix (thinking maybe the /nextcloud/.well-known
might be the problem), but that didn't work ether. I tried messing with the rewrite rules, but in the end, I couldn't figure it

Maybe someone here will see it as something obvious.

Posts: 144
Joined: Tue Dec 12, 2017 9:17 pm

Re: nextcloud + mac os x Contacts app

Post by j12t »

To clarify: please correct me if I misunderstand you:

* You are attempting to subscribe to both a calendar, and an address book, from both MacOS and iOS.
* The calendar works on both devices
* The contacts work on iOS but not on the Mac?

If it works on one but not the other, how do the incoming HTTP requests different between the two different client devices?

P.S. This seems rather similar.

Posts: 3
Joined: Fri Jan 05, 2018 7:54 am

Re: nextcloud + mac os x Contacts app

Post by mike865 »

Your clarification is correct. on ios contacts and calendars work. with max os x, calendar works, but contacts do not.

I tried the troubleshooting page you sent me to, and I got contacts to connect to nextcloud, but any operation
would fail with a 405 code. Same behavior as before

I think the problem is redirection of .well-known links

... and I just fixed it.

I had read the section called "Service Discovery" here... ... oting.html

and what I tried this time was not to mess with .htaccess, because I noticed the web server
processes were running with this command line:

/usr/bin/httpd -k start -DFOREGROUND -f /etc/httpd/conf/httpd-ubos.conf

so I edited /etc/httpd/conf/httpd-ubos.conf like this:

Code: Select all

  ServerRoot "/etc/httpd"

  DocumentRoot /srv/http/placeholders/nosuchsite

+ Redirect 301 /.well-known/carddav /nextcloud/remote.php/dav
+ Redirect 301 /.well-known/caldav /nextcloud/remote.php/dav

  # Ubuntu-style module management
  Include /etc/httpd/ubos/mods-enabled/*.load
and everything worked.

Even better, I could use just the plain URL like instead of the very long long
url like<username>

I realize this fix wasn't as elegant as it should be, but it does work, and I hope it helps!

Post Reply