Page 1 of 1

Problems installing Nextcloud in ubos 13

Posted: Sun Apr 08, 2018 10:57 am
by claus_chr
I have tried to install Ubos 13 with the nextcloud app, but can't make it work. I followed the instructions in the video. After booting ubos I could ping the raspberry pi 3, and I could ssh into it. I ran

Code: Select all

    sudo ubos-admin update
    sudo ubos-admin createsite
and that seemed to work as well. createsite terminated (after quite a long wait) with

Code: Select all

Installed site s442c112eca35b73535ca2851f16e67a594a1af1c at http://ubos-raspberry-pi2.local/
However, trying to connet to the site the browser responded that it could not connect to the server www.ubos-raspberry-pi2.local; and after exiting the ssh session I could no longer ping the raspberry pi nor ssh into it again.

Am I missing something?

My device is a Raspberry pi 3, I am using a ubos staff, a 16 GM micro sd card and the ethernet goes through a netgear router.

Re: Problems installing Nextcloud in ubos 13

Posted: Mon Apr 09, 2018 3:32 am
by j12t
The easiest thing would be to connect a keyboard and a monitor to the Pi, and determine that you are indeed connecting to the correct IP address. This would also show you if there is a boot problem or such.

Oh, and the mDNS hostname does not have a www in front. Some browsers love to add that; why I don't know.

Re: Problems installing Nextcloud in ubos 13

Posted: Wed Apr 11, 2018 10:30 pm
by claus_chr
Thanks for the advice. I have reinstalled UBOS - this time with a monitor and a keyboard attached (but using * for the hostname when installing nextcloud). The result seems to be the same as before. After booting UBOS I get a positive response doing

Code: Select all

ping ubos-raspberry-pi2.local
and I can ssh into it as shepherd@ubos-raspberry-pi2.local.

However, after running

Code: Select all

ubos-admin update
and then installing nextcloud I can no longer ping the raspberry pi, ssh into it as shepherd@ubos-raspberry-pi2.local nor get access to the nextcloud site at http://ubos-raspberry-pi2.local (my browser did try this address first and when that failed tried slabbing a www in front - sorry I forgot to remove that in my previous post). UBOS is up and running with Nextcloud, however. I can ping it, ssh into it and access the website if I use the IP address in stead of ubos-raspberry-pi2.local. The first couple of pages were extremely slow in loading but after that everything has worked fine.

So problem solved :D