Page 1 of 1

Createsite failed

Posted: Sat Dec 29, 2018 6:00 pm
by rockhjohnson
Hi,

After following UBOS instructions/questions the createsite app nextcloud fails because of see attached screenshot.

TY

Kind regards
Rock

Re: Createsite failed

Posted: Sat Dec 29, 2018 9:47 pm
by j12t
Can you please post the exact sequence of steps that led to this error? Also, we need hardware platform / virtualization platform and version, and the version of the image you are using.

Re: Createsite failed

Posted: Sun Dec 30, 2018 2:27 pm
by rockhjohnson
Hi, yes, I was a bit short on info.

Host Os:Windows 10
Hardware: Surface Pro 3
Hypervizer: VirtualBox 6.0
Allocated memory: 4096Mb
CPU: 2 cores
ubos_yellow_x86_64-VBox_LATEST.VMDK

Created the VM, Linux: other Linux (64-bit), Network: Bridged adapter.
Booted logged in as root, waited a sec, did systemctl is-system-running = running.
ip addr = online
sudo ubos-admin update = updated keyring
Decided hostname = ubos-vbox-pc.local
udo ubos-admin createsite
** First a few questions about the website that you are about to create:
Hostname (or * for any): ubos-vbox-pc.local
Site admin user id (e.g. admin): admin
Site admin user name (e.g. John Doe): admin
Site admin user password (e.g. s3cr3t): ********
Repeat site admin user password: *********
Site admin user e-mail (e.g. foo@bar.com): root@localhost
** Now a few questions about the app(s) you are going to deploy to this site:
First app to run (or leave empty when no more apps): nextcloud
Downloading packages...
App nextcloud suggests context path /nextcloud
Enter context path: /nextcloud
Any accessories for nextcloud? Enter list:nextcloud-bookmarks, nextcloud-calendar, nextcloud-contacts, nextcloud-mail, nextcloud-news, nextcloud-notes, nextcloud-spreed, nextcloud-tasks, nextcloud-cache-redis
## I tried this also without any accessories to no avail.
Next app to run (or leave empty when no more apps):
Downloading packages...
Deploying...
## the results are in the screenshot.

Thanks for your great work and effort, I like the idea to be able to deploy multiple apps like Cloudron but on localmachine.
I hope to have shared enough info to solve this isue, otherwise I will be as much of assistance as I can be.

Kind regards
Rock

Re: Createsite failed

Posted: Sun Dec 30, 2018 3:01 pm
by rockhjohnson
Hi, nevermind, I went through all the steps again but this time I filled in a actual emailID here: Site admin user e-mail (e.g. foo@bar.com): root@localhost
I added no accessories and it got deployed.

Thanks for your time and effort.

Kind regards
Rock