Page 1 of 1

Tried to create a tor site

Posted: Fri Sep 11, 2020 11:22 pm
by ralphshinevar
Hi.

I went through the steps to create a tor site. When I was finished, it took awhile and then was told tor "timed out" When I listsites, I get a ERROR: Site JSON: invalid host name, is: -not-assigned-yet The admin status says * System service tor has failed. Also, I cannot do the ubos-admin createsite --tor command. It gives the same error. Not sure what to do next.

Re: Tried to create a tor site

Posted: Sat Sep 12, 2020 4:27 am
by j12t
What platform are you on, release channel, latest software update run when?

Re: Tried to create a tor site

Posted: Sat Sep 12, 2020 2:38 pm
by ralphshinevar
I am using the vbox version of UBOS. I am on the yellow channel. I did an update right after downloading UBOS and setting it up in Virtual Box. I am using Linux Lite 5 on my workstation.

Re: Tried to create a tor site

Posted: Sat Sep 12, 2020 7:23 pm
by j12t
Hmm, it appears Tor integration is currently broken. Not a whole lot of people use this, which is probably why we didn't catch it before.

https://github.com/uboslinux/ubos-admin/issues/775

Re: Tried to create a tor site

Posted: Sun Sep 13, 2020 8:01 pm
by ralphshinevar
Hi. Will you be fixing the tor integration then? Is there anything I can do in the meantime? Thanks.

Re: Tried to create a tor site

Posted: Mon Sep 14, 2020 3:06 am
by j12t
It will get fixed. Not sure it will make it into the next release though which is in progress.

Re: Tried to create a tor site

Posted: Wed Sep 16, 2020 1:09 pm
by ralphshinevar
I hope you can get this fix in the next release. I want to use UBOS in tor since I have another server using port forwarding. :)