Problems installing

You are using UBOS on a Rasberry Pi. Please state which model you are using, e.g. Zero, Zero W, model 3 or such.
Post Reply
moho
Posts: 6
Joined: Tue Dec 11, 2018 8:09 pm

Problems installing

Post by moho » Tue Dec 11, 2018 8:22 pm

UBOS was downloaded unpressed and installed on a SD, I put it into the Raspberry PI2 and it started to install. Until ubos-raspberry-pi2 login...I wrote root and them it says root@ubos-raspberry-pi2~]# the cursor is blinking but nothing else happens. I wrote:
% systemctl is-system-running and the answer was -bash:fg: %: no such job



j12t
Posts: 90
Joined: Tue Dec 12, 2017 9:17 pm
Contact:

Re: Problems installing

Post by j12t » Wed Dec 12, 2018 9:01 pm

It sounds like you got a root shell? If so, installation seems to have worked. What do you think is the problem? :-)

Perhaps you want to read some more in the documentation, such as: https://ubos.net/docs/users/firstsite.html

moho
Posts: 6
Joined: Tue Dec 11, 2018 8:09 pm

Re: Problems installing

Post by moho » Fri Dec 14, 2018 1:09 pm

:D It is true. I followed the procedure and was able to run Nextcloud on RPI2...but after some playin I realized, that only the SD card was installed and not the attached WD 1TB disk connected to the RPI2 via USB. So no space. And secondly, I did not install the https, I went through the procedure as describes, but It says, that apps are already installed and it did not go any further.

moho
Posts: 6
Joined: Tue Dec 11, 2018 8:09 pm

Re: Problems installing

Post by moho » Sun Dec 16, 2018 9:09 pm

I feel a bit stupid, but is it possible, that I missed the how-to or step-by-step procedure, how to install and get to run ubos with Raspberry PI2B with an 1TB USB HDD attached to?


moho
Posts: 6
Joined: Tue Dec 11, 2018 8:09 pm

Re: Problems installing

Post by moho » Wed Dec 19, 2018 7:57 am

It doesn't help me and I'm a bit angry at myself and disappointed :-(

- I can't get it run on my HDD attached via USB to the RPI2b, I went through the procedure Word by Word, but it is also true, that I don't really understand point 6 and 7:

6.Update /etc/fstab so that the disk will be automatically mounted after a reboot. This is important. If your data disk is not available at boot time, your device will likely hang instead of booting. An easy way to determine what to add to /etc/fstab comes courtesy of the Arch Linux install scripts:

% sudo pacman -S arch-install-scripts
% genfstab /

7.Compare the output of this script, with the content of /etc/fstab. Ignore the lines that start with a #. You will likely find a single line that’s different. Add this line to the end of /etc/fstab. It probably looks something like this:

/dev/sdb2 /ubos btrfs rw,relatime,space_cache,subvolid=5,subvol=/ 0 0


So I will start again from scratch and install Ubos...but...where to define the HDD or 2 HDD's connected via USB to RPI2B I want to be used???

j12t
Posts: 90
Joined: Tue Dec 12, 2017 9:17 pm
Contact:

Re: Problems installing

Post by j12t » Thu Dec 20, 2018 12:59 am

I guess we could be more detailed in the instructions. (Although if you do this setup, and you are not quite sure what you are doing, and something goes wrong some time down the road, chances are you can't repair it yourself.)

The key command is something like "sudo mount /dev/sda1 /ubos" but the details depend on a bunch of things, include the formatting of your hard drive.

You don't need to go through the install process again, it has nothing to do with it.

moho
Posts: 6
Joined: Tue Dec 11, 2018 8:09 pm

Re: Problems installing

Post by moho » Sun Dec 30, 2018 12:43 pm

Ok. Do you plan to update the how-to, to make it easier and understandable for common people, because I saw, that there were some similar questions already?
I agree, that there is always the chance that something goes wrong, but basicly, if the how-to is good, the chance is low.

j12t
Posts: 90
Joined: Tue Dec 12, 2017 9:17 pm
Contact:

Re: Problems installing

Post by j12t » Mon Dec 31, 2018 7:25 pm

There isn't much of a point to rewrite documentation for UBOS that exists all over the web on Linux in general. But if you have a good idea how to improve the wording, pull requests welcome :-)

moho
Posts: 6
Joined: Tue Dec 11, 2018 8:09 pm

Re: Problems installing

Post by moho » Tue Feb 26, 2019 7:16 pm

Thank you for your reply.
I can not give really a proposal on how to do the wording, just as a idea, maybe prepare a step-by-step (with copy/paste) instructions, with the most common sitations as seen also in the forum. How to add a USB external HDD, maybe even two (if possible).
If I would now how to make it, I would write it :D

Post Reply