To install new Accessories

Questions and discussions about Indie Computing's UBOSbox
Post Reply
criky
Posts: 54
Joined: Fri Jul 05, 2019 4:24 am

To install new Accessories

Post by criky »

Hi :)
After the installation of the newest UBOS(2019-11-12), I can see the new phenomenon in regard to accessories that I've never seen of old versions.
I just want to follow the previous process(below) I'd taken when I want to have new accessories.

1. "sudo ubos-admin showsite -s s... --json > mysite.json"
2. Edit that file, and add new accessory names. Save.
3. re-deploy the updated file: "sudo ubos-admin deploy --file mysite.json"

Whenever I try these, below message pops, so please see below two different cases.
==> I just added the names of the new accessories to accessoryids of each Site JSON file.

Is there any update for the process, or any other way to install?
Attachments
2..png
2..png (9.97 KiB) Viewed 3114 times
1..png
1..png (13.44 KiB) Viewed 3114 times



j12t
Posts: 144
Joined: Tue Dec 12, 2017 9:17 pm
Contact:

Re: To install new Accessories

Post by j12t »

You likely have a syntax error or errors in your Site JSON file. Please post the whole JSON file (removing just credential info).

criky
Posts: 54
Joined: Fri Jul 05, 2019 4:24 am

Re: To install new Accessories

Post by criky »

Hi there :) , please see below my Site JSON file for details which corresponds to the above second shot(mysite.json).
Nothing special though, as it was implemented and deployed in the previous UBOS without problems.
So I thought it should work with the new UBOS version as well unless there would be any changes in its syntax.
Can you see anything that might affect to the syntax?
Attachments
4..png
4..png (108.17 KiB) Viewed 3093 times
3..png
3..png (150.42 KiB) Viewed 3093 times

j12t
Posts: 144
Joined: Tue Dec 12, 2017 9:17 pm
Contact:

Re: To install new Accessories

Post by j12t »

Could post the actual file, instead of just a screen shot? Sometimes there are strange characters in the file and we won't see them in a screenshot.

Also, are there currently site(s) running on that device? If so, can you also post the output of "sudo ubos-admin listsites --json"? And does "sudo ubos-admin update" work?

criky
Posts: 54
Joined: Fri Jul 05, 2019 4:24 am

Re: To install new Accessories

Post by criky »

Hi there, :)
After all, this issue has been resolved in an unexpected way.
The problem was mine, for I'd completely forgotten making the codes I want installed on the box at the very beginning.
When I invoke

Code: Select all

sudo pacman -S xxxx
, followed by implementation of the new configurations of json files, it's done.

Thanks for your support and advice as always.
Have a great weekend.

Post Reply